Commit 3082d1a5 authored by ueli heuer's avatar ueli heuer

Update readme.txt

parent 12507afc
......@@ -5,11 +5,14 @@ mod_honeypot for Apache 2.4
1.0 Scope
This document describes the function, installation and configuration of the
mod_honeypot loadable module for Apache 2.2.
mod_honeypot loadable module for Apache 2.4.
The Project Honeypot API (https://www.projecthoneypot.org/httpbl_api.php) is
incorporated by reference.
As the Honeypot Project is focused on IPv4, this module works only with IPv4
addresses. IPv6 requests will 'walk through' the module
2.0 Function
......@@ -25,7 +28,7 @@ the installation.
3.1 Host System Requirements
The host system must have an Apache 2.2 server capable of inserting loadable
The host system must have an Apache 2.4 server capable of inserting loadable
modules.
The usual linux utilities, including make and gcc, are required.
......@@ -54,7 +57,7 @@ abbreviated description of how it operates.
4.1 Basic Function
mod_honeypot is an Apache 2.2 loadable module which checks to see if an
mod_honeypot is an Apache 2.4 loadable module which checks to see if an
incoming request is emanating from an IPv4 address which is known to the
Project Honeypot DNS blocklist. If this is the case, and the Project
Honeypot information about the address meets the match criteria, the module
......@@ -377,9 +380,9 @@ This module was built, tested and run under Debian linux. Problems can be
expected building and running it under a Windows version of Apache 2.
8.2 Tested Under Apache 2.2
8.2 Tested Under Apache 2.4
This module was built, tested and run under Apache 2.2. No guarantee is made
This module was built, tested and run under Apache 2.4. No guarantee is made
that it operates under any other version. Feedback on this issue from users
running other versions of Apache 2 is encouraged; see section 9 below.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment